Skip to content
Infinite Audience Docs
Search
Ctrl
K
Cancel
GitHub
Select theme
Dark
Light
Auto
Start here
Welcome
Choose a workflow
Identity & Enrichment
Overview
What you can send
How matching works
Spatial matching
What comes back
Person IDs & privacy
Record licensing
Performance & scale
Platform how-tos
Find your way around
Enrich a customer file
Infinite Audience Agent
Build with Segment Studio
Build an audience
Use integration matches
Integrations
Overview
HubSpot
Shopify
Klaviyo
Zapier
Build with Infinite Audience
Developer overview
Python & npm libraries
Enrich records with the API
Enrich a file with the API
Authentication
API keys
Scopes
OAuth for partners
MCP for AI agents
A2A agent
Webhooks
Code examples
API playground
API Reference
Overview
Auth
Overview
Exchange API key for an access token
OAuth
Overview
Begin an OAuth 2.0 authorization request
Exchange an authorization code, device code, or refresh token for an access token
Begin an OAuth device authorization for an A2A client
Revoke a token (RFC 7009)
Register a public OAuth client (RFC 7591 fallback)
OAuth 2.0 authorization server metadata (RFC 8414)
OpenID Connect discovery metadata
Public OIDC ID-token signing keys
Get current person-bound OIDC identity
Get current person-bound OIDC identity
OpenAI MCP host ownership challenge
REST protected-resource metadata (RFC 9728)
MCP protected-resource metadata (RFC 9728)
A2A protected-resource metadata (RFC 9728)
Triggers
Overview
List webhook-trigger subscriptions
Create a webhook-trigger subscription
Revoke a webhook-trigger subscription
Discovery
Overview
Discover available filter attributes
Count records matching criteria
Return masked sample rows matching criteria
Cross-tabulate two dimensions across a population
Calculate record overlap between two criteria sets
Campaigns
Overview
List campaigns
Create a campaign
Get a campaign
Archive a campaign
Update a campaign
Link an audience to a campaign
Unlink an audience from a campaign
Segments
Overview
List segments for the caller's org
Create a segment
Get a segment by ID
Permanently remove a segment
Partially update a segment
Recount a segment
Get demographic breakdown for a segment
List audiences referencing a segment
Duplicate a segment with lineage tracking
Bulk archive segments
Bulk update segments
Bulk hard-delete segments
Refresh a segment against the latest data
Confirm column mapping overrides for a matched segment
Abort a staged (hitl:true) matched-segment upload without confirming
Report that a matched segment's client-side re-upload failed
Bulk create segments
Audiences
Overview
List audiences for the caller's org
Create an audience
Get an audience by ID
Update an audience
Delete an audience
Partially update an audience
Duplicate an audience with lineage tracking
Recompute record count for an audience
Get demographic breakdown for an audience
Refresh a member segment and this audience's composed metadata
Confirm column mapping overrides for a matched audience
Abort a staged (hitl:true) matched-segment upload without confirming
Bulk archive (soft-delete) audiences
Bulk update audiences
Bulk create audiences
Deliveries
Overview
Delivery quote
Bulk deliver multiple audiences
List deliveries for an audience
Create a delivery for an audience
Get a single delivery
List deliveries for a file match job
Deliver a file match job
List org-wide deliveries
Enrichment
Overview
Analyze matched segment column mapping
Attribute catalog with pricing
Current data release version
Micro-batch synchronous match
List file match jobs
Start an async file-based identity resolution job
List micro-batch match runs
Get a micro-batch match run
Get a file match job
Workflows
Overview
Get workflow status
Respond to a HITL workflow gate
Account
Overview
Get organization licence reporting
Get organization licence expiry alert threshold
Set organization licence expiry alert threshold
Get native billing or setup readiness
Get prepaid automatic-recharge state
Configure prepaid automatic recharge
List active paid commits and promotional credits
List invoices with hosted collection links
Start Stripe payment-method onboarding for the billing account
Begin an idempotent credit top-up
Get durable top-up status
Recheck a durable top-up against providers
Open Stripe payment-method and invoice-history settings
Schedule a billing contract change
Schedule contract cancellation
Revert a scheduled cancellation
Get aggregated usage metrics
Settings
Overview
List API keys for the caller's org
Create a self-service API key
Revoke a self-service API key
Get the org's webhook configuration
Configure the org's outbound webhook
Rotate the org's webhook signing secret
Get the caller's own notification preferences
Update the caller's own notification preferences
Get delivery destinations
Update delivery destinations
Get billing preferences
Update billing preferences
Get display timezone
Set display timezone
MCP
Overview
Unsupported standalone MCP event stream
MCP stateless message dispatch
Unsupported MCP session termination
A2A
Overview
Public A2A Agent Card
Legacy A2A Agent Card discovery alias
Send a standard A2A JSON-RPC request
Partnerships
Overview
List retained partnership activity
Get retained partnership activity
List saved integration match collections
Preview a saved-match segment materialization
Build or extend a segment from saved integration matches
Get a saved-match segment materialization
Integrations
Read automatic purchase permission
Preview or approve automatic purchase permission
Revoke automatic purchase permission
Read monthly renewal permission
Preview or approve monthly renewal permission
Revoke monthly renewal permission
Disconnect an outbound integration
Webhooks
Segment build succeeded
Segment build failed
Delivery export completed
Delivery export failed
Administration
Single sign-on
Okta
Microsoft Entra ID
Google Workspace
DNS verification
SSO troubleshooting
GitHub
Select theme
Dark
Light
Auto
Overview
Settings
Section titled “Settings”
Self-service API keys and org configuration
Operations
Section titled “Operations”
GET
/v1/settings/api-keys
POST
/v1/settings/api-keys
DELETE
/v1/settings/api-keys/{id}
GET
/v1/settings/webhook
PUT
/v1/settings/webhook
POST
/v1/settings/webhook/secret
GET
/v1/settings/notifications
PUT
/v1/settings/notifications
GET
/v1/settings/delivery-destinations
PUT
/v1/settings/delivery-destinations
GET
/v1/settings/billing-preferences
PUT
/v1/settings/billing-preferences
GET
/v1/settings/timezone
PUT
/v1/settings/timezone